close window AlcoholEdu

AlcoholEdu System Requirements

EverFi, Inc. supports a variety of computer configurations for all versions of AlcoholEdu. While we strongly recommend using the latest version of one of the listed browsers and the latest version of Flash, we do support some older versions. Please refer to the matrix below to confirm that your computer meets these minimum requirements. If you are unsure about your system configuration, you may log on to the course and use the information on the Media Settings page to help you identify any missing requirements.

At this point we are unable to support any AlcoholEdu course on tablets or mobile devices. We strongly recommend you use a computer with one of the operating systems listed below to take the course.

      

Windows PC*

Macintosh*

Operating System
  • Windows XP or later
  • OS X or later
    Internet Connection Recommend wired as wireless can be slower.
    Browser
  • Internet Explorer 7 or later
  • Mozilla Firefox 1.0 or later
  • Google Chrome
  • Mozilla Firefox 1.0 or later
  • Google Chrome
  • Safari 5.1 or later
  • Flash Player** Flash Player 8 or later
    Flash Player 8 or later
    Sound*** speakers or headphones
    Monitor 1024 by 768 pixel display
    1024 by 768 pixel display

    **Note: The Flash Player is preinstalled on most systems, although an upgrade may be necessary.
    ***Note: If you do not have sound, it is best to find a computer that does. If this is not possible, choose the closed captioning option when taking the course.

    [back to top]